原来编译 FreeMind 所需的依赖包只有这么几个

LiYanrui posted @ Sep 02, 2008 03:06:56 AM in GNU/Linux & Unix with tags gentoo freemind , 2815 阅读

在 Gentoo 中,如果用户未安装 JAVA 程序的运行与编译环境,通过 portage 安装 FreeMind 会依赖大约 82 个包,而且版本总比 SF 上的慢好几拍。所以,一直以来,我都是使用 FreeMind 发布的 bin 包,这样我的系统中只需安装一个 sun-jdk 1.6 即可。今天,发现 SF 上已经释出 FreeMind 0.9 beta 20 版本,不过这次居然没有提供 Linux 版本,我很费解。由于我是新版本狂,总是要想方设法弄到新版本来尝试,所以就下了 FreeMind 最新的源码包,想自己编译,readme.txt 上说需要 ant 才能编译。如果直接 emerge ant,还是会有很多包,但是我发现只需要 ant-core 就够了。经过一番尝试,最后得出的结论是:要自己编译 FreeMind,只需要 ant-core,而安装 ant-core 只需 javatoolkit 和 jdk 1.6。这个结论让我再一次对 portage 中的 freemind 表示不满。


登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter